Back to overview
Degraded

Heart mod errors.

Jan 05 at 12:45pm HST

Resolved
Jan 05 at 05:22pm HST

Server Errors have been fixed. all normal operations will resume.

Created
Jan 05 at 12:45pm HST

There are current issues that keep persisting with the heart mod were if you fall in lava you lose 6-8 hearts. THIS IS A ERROR. If you are eliminated please text me, you will NOT loose any of items if so.